summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-06 19:13:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-06 23:16:56 +0300
commitd967ffb367bfbc1600ff6da179fe96b6f5c5c60c (patch)
treeb1692043b7f4905b19dff577e617a5278769a691 /gnu
parenta9c89cd11b7f8fee63fbb8b1180f46784af3cb81 (diff)
gnu: python-http-client: Fix test suite.
* gnu/packages/python-web.scm (python-http-client)[arguments]: Add a phase to adjust the tests to not be dependant on the current date. Change-Id: I94f512c9b019173f6e15e04791dbfc662fc93c89
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c04f100c1c..ee19c8bdc4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2015-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2013, 2014, 2015, 2016, 2020 Andreas Enge <andreas@enge.fr>
@@ -8843,6 +8843,14 @@ possible, supporting most common functionality.")
(use-modules (guix build utils))
(delete-file "tests/profile.py")))))
(build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ ;; The test expects the copyright to be updated each year.
+ (substitute* "tests/test_daterange.py"
+ (("time\\.strftime\\(\"%Y\"\\)") "2022")))))))
(synopsis "HTTP REST client for Python")
(description
"This package provides access to any RESTful or RESTful-like API.")