summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-02-03 23:26:34 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-03 23:44:44 +0100
commitda0f959e6f0ff308ac919238f6f7f7239145f1ac (patch)
tree0d7009f5906db9ad818f67b7138107808032ea2f /gnu
parentdd3ec180f89e6229e972a6df7c625fdb66175d9d (diff)
gnu: Add emacs-srv.
* gnu/packages/emacs-xyz.scm (emacs-srv): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dec8828ca1..fe9d243587 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25001,6 +25001,29 @@ later.")
them in your web browser.")
(license license:expat))))
+(define-public emacs-srv
+ (package
+ (name "emacs-srv")
+ (version "0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/legoscia/srv.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1a8pqhdi7m3lis5ad2f74s1sy8zpxlwvfsvd80lw746235x2v06z"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/legoscia/srv.el")
+ (synopsis "Emacs Lisp library to perform SRV DNS requests")
+ (description
+ "SRV implements RFC 2782 (SRV records). It is used to look up hostname
+and port for a service at a specific domain. There might be multiple results,
+and the caller is supposed to attempt to connect to each hostname+port in
+turn.")
+ (license license:gpl2+)))
+
(define-public emacs-github-review
(let ((commit "a13a3b4f1b6114a32af843971a145ab880f51232")
(revision "2"))