summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-19 08:11:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-19 08:22:21 +0200
commitda1f3aff2ea9a98651ebc69c8385ba136fe2e325 (patch)
tree970e9eb4cafe57ee8043f8c3503a8c70ae13476f /gnu
parent5aba852c18a4a275ffe98bd5cdab71bb9850f66d (diff)
gnu: emacs-ess: Fix build.
* gnu/packages/statistics.scm (emacs-ess)[arguments]<#:phases>: Fix syntax category for a skipped a test. Extend syntax to check for tests in more files. Change-Id: I7344637107920288995893dec2b1e6642d11f95e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index af2ae9ec05..fe352f1b4e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6922,34 +6922,33 @@ Java package that provides routines for various statistical distributions.")
(let-syntax
((disable-tests
(syntax-rules ()
- ((_ file ())
+ ((_ ())
(syntax-error "test names list must not be empty"))
- ((_ file (test-name ...))
- (substitute* file
+ ((_ (test-name ...))
+ (substitute* (find-files "test" "\\.el$")
(((string-append "^\\(ert-deftest " test-name ".*")
all)
(string-append all "(skip-unless nil)\n"))
...))))
(disable-etests ;different test syntax
(syntax-rules ()
- ((_ file ())
+ ((_ ())
(syntax-error "test names list must not be empty"))
- ((_ file (test-name ...))
- (emacs-batch-edit-file file
- '(progn
- (mapc (lambda (test)
- (goto-char (point-min))
- (search-forward
- (format "etest-deftest %s " test))
- (beginning-of-line)
- (kill-sexp))
- (list test-name ...))
- (basic-save-buffer)))))))
- (disable-tests (list "test/ess-test-inf.el"
- "test/ess-test-r.el")
- ("ess--derive-connection-path"
- ;; Looks like an off-by-one error.
- "ess--command-browser-unscoped-essr"
+ ((_ (test-name ...))
+ (for-each
+ (lambda (file)
+ (emacs-batch-edit-file file
+ '(progn
+ (dolist (test (list test-name ...))
+ (goto-char (point-min))
+ (let ((s (format "etest-deftest %s "
+ test)))
+ (when (search-forward s nil t)
+ (beginning-of-line)
+ (kill-sexp))))
+ (basic-save-buffer))))
+ (find-files "test" "\\.el$"))))))
+ (disable-tests ("ess--derive-connection-path"
"ess-eval-line-test"
"ess-eval-region-test"
"ess-mock-remote-process"
@@ -6957,9 +6956,10 @@ Java package that provides routines for various statistical distributions.")
"ess-r-load-ESSR-github-fetch-yes"
"ess-set-working-directory-test"
"ess-test-r-startup-directory"))
- (disable-etests "test/ess-test-r-eval.el"
- ("ess-r-eval-ns-env-roxy-tracebug-test"
- "ess-r-eval-sink-freeze-test")))))
+ (disable-etests ("ess-r-eval-ns-env-roxy-tracebug-test"
+ "ess-r-eval-sink-freeze-test"
+ ;; Looks like an off-by-one error.
+ "ess--command-browser-unscoped-essr")))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests? (invoke "make" "test"))))))))