summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 11:44:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 11:44:52 +0200
commitda88e39ce0d9a7aaae36a7a5fe8706ab15cde18e (patch)
treed4f547525345fe11f0e6a93fb820b2f8ae28637c /gnu
parentc2bb0beef7d67f56aaa35f6d0969084b999bdd30 (diff)
gnu: Add python-azure-storage-blob.
* gnu/packages/python-web.scm (python-azure-storage-blob): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index eb94cb3de6..689a99b518 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6713,6 +6713,26 @@ Python.")
Python.")
(license license:expat)))
+(define-public python-azure-storage-blob
+ (package
+ (name "python-azure-storage-blob")
+ (version "12.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "azure-storage-blob" version ".zip"))
+ (sha256
+ (base32 "1xv23ph822qywjxs81say9xi5dzmvxcii6sww6d1hvd83iyz1npn"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-azure-core python-cryptography python-msrest))
+ (native-inputs (list unzip))
+ (home-page "https://github.com/Azure/azure-sdk-for-python/")
+ (synopsis "Microsoft Azure Blob Storage client library for Python")
+ (description "This package provides the Microsoft Azure Blob Storage
+Client Library for Python.")
+ (license license:expat)))
+
(define-public python-w3lib
(package
(name "python-w3lib")