summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-13 15:59:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 16:31:55 +0100
commitde30c74b639c8739263973d0e49344b727b2c163 (patch)
tree833827ee3d5fac61c8f7577d6021c9f1a6167228 /gnu
parent057579495f333c48b84454d7067977e19e680b2f (diff)
gnu: bioawk: Use gexp.
* gnu/packages/bioinformatics.scm (bioawk)[arguments]: Use gexp and simplify 'install phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm35
1 files changed, 16 insertions, 19 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f07938d42f..f9a51910d9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -802,26 +802,23 @@ provides the Ribotaper pipeline.")
(base32
"1pxc3zdnirxbf9a0az698hd8xdik7qkhypm7v6hn922x8y9qmspm"))))
(build-system gnu-build-system)
- (inputs
- (list zlib))
- (native-inputs
- (list bison))
+ (inputs (list zlib))
+ (native-inputs (list bison))
(arguments
- `(#:tests? #f ; There are no tests to run.
- ;; Bison must generate files, before other targets can build.
- #:parallel-build? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; There is no configure phase.
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (man (string-append out "/share/man/man1")))
- (mkdir-p man)
- (copy-file "awk.1" (string-append man "/bioawk.1"))
- (install-file "bioawk" bin))
- #t)))))
+ (list
+ #:tests? #f ; There are no tests to run.
+ ;; Bison must generate files, before other targets can build.
+ #:parallel-build? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (replace 'install
+ (lambda _
+ (let ((bin (string-append #$output "/bin"))
+ (man (string-append #$output "/share/man/man1")))
+ (mkdir-p man)
+ (copy-file "awk.1" (string-append man "/bioawk.1"))
+ (install-file "bioawk" bin)))))))
(home-page "https://github.com/lh3/bioawk")
(synopsis "AWK with bioinformatics extensions")
(description "Bioawk is an extension to Brian Kernighan's awk, adding the