summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:09:37 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 05:11:31 +0200
commitde957d959545ed25567916060222121140b8547f (patch)
tree2b10c06b8b21874422a375e95d08596dbbc88426 /gnu
parentb42a72bed1c6cda9b79a65ec42ce892821f1bb29 (diff)
gnu: camlp4@4.07+1: Don't use unstable tarball.
* gnu/packages/ocaml.scm (camlp4-4.07)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c06b5a09c2..2a2a052de5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -623,14 +623,15 @@ syntax of OCaml.")
(inherit camlp4-4.02)
(name "camlp4")
(version "4.07+1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ocaml/camlp4/archive/"
- version ".tar.gz"))
- (sha256
- (base32
- "143hhxv1i6aq413z0i1pynrjcfl2g5gnh5r3863v6h9z0riqknzc"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/camlp4.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cxl4hkqcvspvkx4f2k83217rh6051fll9i2yz7cw6m3bq57mdvl"))))
(properties
`((ocaml4.02-variant . ,(delay camlp4-4.02))))
(native-inputs