summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2023-09-17 09:45:34 +0200
committerChristopher Baines <mail@cbaines.net>2023-09-25 11:30:03 +0100
commite0269ad9caed52d998214061422754c84395b4cc (patch)
tree79f547350847d0987aab901bf7bffb8d811e90d3 /gnu
parenta5477e3a82114ce2909e63a07c7e6df6da617821 (diff)
gnu: jq: Update to 1.7.
* gnu/packages/web.scm (jq): Update to 1.7. [home-page]: Update URL. [source]: Simplify snippet. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d8acc13e8a..5d873e0884 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5134,21 +5134,19 @@ It uses the uwsgi protocol for all the networking/interprocess communications.")
(define-public jq
(package
(name "jq")
- (version "1.6")
+ (version "1.7")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/stedolan/jq"
+ (uri (string-append "https://github.com/jqlang/jq"
"/releases/download/jq-" version
"/jq-" version ".tar.gz"))
(sha256
- (base32 "0wmapfskhzfwranf6515nzmm84r7kwljgfs7dg6bjgxakbicis2x"))
+ (base32 "0qnv8k9x8i6i24n9vx3cxgw0yjj1411silc4wksfcinrfmlhsaj0"))
(modules '((guix build utils)))
(snippet
- '(begin
- ;; Remove bundled onigurama.
- (delete-file-recursively "modules")
- #t))))
+ ;; Remove bundled onigurama.
+ '(delete-file-recursively "modules"))))
(inputs
(list oniguruma))
(native-inputs
@@ -5161,7 +5159,7 @@ It uses the uwsgi protocol for all the networking/interprocess communications.")
(list valgrind)
'())))
(build-system gnu-build-system)
- (home-page "https://stedolan.github.io/jq/")
+ (home-page "https://jqlang.github.io/jq/")
(synopsis "Command-line JSON processor")
(description "jq is like sed for JSON data – you can use it to slice and
filter and map and transform structured data with the same ease that sed, awk,