summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 22:17:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:35 +0100
commite0ba59a9f88e1b38cd7c0bd2fa6fd7b9076842cb (patch)
tree6c893a5f95bf068d3de5d8ac214d8535e6c715d3 /gnu
parentfe4f81bc6f2a597cb0b9dec2ad20d270dde1d435 (diff)
gnu: Add ghc-pretty-show-for-haskell-src-exts.
* gnu/packages/haskell.scm (ghc-pretty-show-for-haskell-src-exts): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1b39a1eba3..06f989b94d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -977,6 +977,19 @@ complex generic values into an interactive Html page, for easier
examination.")
(license license:expat)))
+(define-public ghc-pretty-show-for-haskell-src-exts
+ (package (inherit ghc-pretty-show)
+ (name "ghc-pretty-show")
+ (version "1.6.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/pretty-show/"
+ "pretty-show-" version ".tar.gz"))
+ (sha256
+ (base32
+ "133s4l1gk46saf6ycm785rswycy8g3j0qqrv93b5wp8cp50kd0ww"))))))
+
(define-public ghc-haskell-src-exts
(package
(name "ghc-haskell-src-exts")