summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-06 13:14:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-06 13:15:21 +0200
commite32db0fa0f6d2da7dd7aebf6016856d9b3db0cd6 (patch)
tree2b298bf1448d687ffabd6e7017b5c2029b00092e /gnu
parent73c0e477e5be4aa731f25fad4f6589297e77c77b (diff)
gnu: vigra: Disable broken test.
* gnu/packages/image.scm (vigra)[arguments]: Add phase "disable-broken-test"; enable parallel build.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 37d51f1e51..0f15685d33 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2013, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2014, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Amirouche Boubekki <amirouche@hypermove.net>
;;; Copyright © 2014, 2017 John Darrington <jmd@gnu.org>
@@ -811,7 +811,14 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
("python2-sphinx" ,python2-sphinx)))
(arguments
`(#:test-target "check"
- #:parallel-build? #f ; parallel builds trigger an ICE
+ #:phases
+ (modify-phases %standard-phases
+ ;; See https://github.com/ukoethe/vigra/issues/432
+ (add-after 'unpack 'disable-broken-test
+ (lambda _
+ (substitute* "test/fourier/CMakeLists.txt"
+ (("VIGRA_ADD_TEST.*") ""))
+ #t)))
#:configure-flags
(list "-Wno-dev" ; suppress developer mode with lots of warnings
(string-append "-DVIGRANUMPY_INSTALL_DIR="