summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-27 15:23:36 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-27 22:51:58 +0000
commite6c6e1b8a40431c2f9458ed0968787235e91f8ac (patch)
tree1fed8c43af5d41f8d659c7e63dec91c6a548d781 /gnu
parent25f7db97c3f03a1c8385e78d336c76614a8880bc (diff)
gnu: python-asdf: Speed up tests.
* gnu/packages/astronomy.scm (python-asdf): Enable parallel tests to speed them up. [arguments] <#:test-flags>: Add it with "-n" option. [native-inputs]: Add python-pytest-xdist. Change-Id: I5a369e8f3ca43b9ba88c1053d0c55d218e6adc43
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 49f2ac7268..0e8b941bbe 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4093,6 +4093,10 @@ between image and reference catalogs. Currently only aligning images with
(sha256
(base32 "1jsk7b4mx04l0a08j832vnl309dba3gjnha9mbd61dzs9ridrfna"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-n" "auto")))
(native-inputs
(list python-fsspec
python-packaging
@@ -4100,6 +4104,7 @@ between image and reference catalogs. Currently only aligning images with
python-pytest
python-pytest-doctestplus
python-pytest-remotedata
+ python-pytest-xdist
python-semantic-version
python-setuptools-scm))
(propagated-inputs