summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-05 19:19:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-06 23:16:50 +0300
commitee926b19ad1bb8d594aa898dbc2db1965f2af0b3 (patch)
tree2b5b9936940dac38b83696f8960eb972fc2fa2c6 /gnu
parent9a19c50b9ba177253bb8188630de3cf4dcf39c44 (diff)
gnu: theorafile: Use test-target.
* gnu/packages/video.scm (theorafile)[arguments]: Add test-target. Remove custom 'check phase. Change-Id: Ia741bc7c202a418801672ffcf88bd7b8577c359e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 04b26e7575..dd2d96925a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5780,13 +5780,10 @@ to convenience of translating and batch processing of multiple documents.")
(build-system gnu-build-system)
(arguments
'(#:make-flags '("CC=gcc")
+ #:test-target "test"
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (replace 'check
- (lambda _
- (setenv "CC" "gcc")
- (invoke "make" "test")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))