summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2019-12-05 23:13:34 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2020-02-17 23:21:03 +0100
commitf0505fde55aa4f5b62452abeba5898378195cef4 (patch)
tree70f50153418abefe0bd6b72b5fcb65a40dd15854 /gnu
parentcacb6b903d6d45606a9d7d91e461e58348e3b80c (diff)
gnu: commencement: coreutils-final: Inherit from coreutils-minimal.
* gnu/packages/commencement.scm (coreutils-final): Inherit from coreutils-minimal.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 8555249c17..13b1936260 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3768,7 +3768,10 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(define coreutils-final
;; The final Coreutils. Treat them specially because some packages, such as
;; Findutils, keep a reference to the Coreutils they were built with.
- (with-boot5 (package-with-bootstrap-guile coreutils)
+ (with-boot5 (package-with-bootstrap-guile
+ (package
+ (inherit coreutils-minimal)
+ (name "coreutils")))
;; Use the final Guile, linked against the
;; final libc with working iconv, so that
;; 'substitute*' works well when touching