summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 14:39:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 14:47:57 +0200
commitf051f68ca2ee5066db266a0df6d8175573a48131 (patch)
treeb294701e2e375f354c2e07f682b2d435e6fdff1c /gnu
parent0d1990b98610b75e982f84ffb370daffe88fb66f (diff)
gnu: Add r-dmrseq.
* gnu/packages/bioconductor.scm (r-dmrseq): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 815efa1ae0..151d74d25c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -14556,6 +14556,52 @@ ensemble machine learning for the estimation of nuisance functions.")
visualizing bisulfite sequencing data.")
(license license:artistic2.0)))
+(define-public r-dmrseq
+ (package
+ (name "r-dmrseq")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "dmrseq" version))
+ (sha256
+ (base32
+ "1jbbjifjsnk9261wqmdwkbzj1w52g6vaanpk4w816ri0fap587m4"))))
+ (properties `((upstream-name . "dmrseq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationhub" ,r-annotationhub)
+ ("r-annotatr" ,r-annotatr)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-bsseq" ,r-bsseq)
+ ("r-bumphunter" ,r-bumphunter)
+ ("r-delayedmatrixstats" ,r-delayedmatrixstats)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-iranges" ,r-iranges)
+ ("r-locfit" ,r-locfit)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-nlme" ,r-nlme)
+ ("r-outliers" ,r-outliers)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/dmrseq")
+ (synopsis "Detection and inference of differentially methylated regions")
+ (description
+ "This package implements an approach for scanning the genome to detect
+and perform accurate inference on differentially methylated regions from Whole
+Genome Bisulfite Sequencing data. The method is based on comparing detected
+regions to a pooled null distribution, that can be implemented even when as
+few as two samples per population are available. Region-level statistics are
+obtained by fitting a @dfn{generalized least squares} (GLS) regression model
+with a nested autoregressive correlated error structure for the effect of
+interest on transformed methylation proportions.")
+ (license license:expat)))
+
(define-public r-tximeta
(package
(name "r-tximeta")