summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-24 20:57:18 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-24 20:57:46 -0400
commitf252e6b8bf539db4ebc811aff40670af7cf26308 (patch)
treed060615a8b193ce7f0de2fbb9c64afeb69861d20 /gnu
parentd90b06cc428146347b0f44faf963c03543854a4e (diff)
gnu: Add python-flake8-isort.
* gnu/packages/python-xyz.scm (python-flake8-isort): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e2bb1ca4ef..ae335cc83f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10739,6 +10739,34 @@ lints.")
TODO notes checker plugin for flake8.")
(license license:expat)))
+(define-public python-flake8-isort
+ (package
+ (name "python-flake8-isort")
+ (version "4.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8-isort" version))
+ (sha256
+ (base32 "05r7z0j9rqgy0a9261bhisairrz6w8hy5hy5kf2mhvhfnx53056q"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (propagated-inputs (list python-flake8 python-isort python-testfixtures))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/gforcada/flake8-isort")
+ (synopsis "Flake8 plugin integrating isort")
+ (description "This package provides a flake8 plugin that integrates isort,
+extending flake8 so that it can warn about badly sorted Python import
+directives.")
+ (license license:gpl2+)))
+
(define-public python-autoflake
(package
(name "python-autoflake")