summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-05-15 09:17:13 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 23:07:39 +0100
commitf2b28d83342d3909e3e8056d653dd095dd120412 (patch)
treef365202c89ce5ae446daecc14d2d16429260cb0a /gnu
parent78e7868bb5276c21a58c0668fde01d462cf4bc31 (diff)
gnu: Add go-github-com-pion-mdns.
* gnu/packages/golang-web.scm (go-github-com-pion-mdns): New variable. Change-Id: Ic141fbaa01b40e60b443a672b5e54d315a114fff Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index fd10ddc1d1..9b0edcc60c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1588,6 +1588,41 @@ which produce colorized output using github.com/fatih/color.")
(description "OpenTracing-Go is a Go implementation of the OpenTracing API.")
(license license:asl2.0)))
+(define-public go-github-com-pion-mdns
+ (package
+ (name "go-github-com-pion-mdns")
+ (version "2.0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/mdns/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03675hx82lx3c8akkxdbkch1z4dbq54r05jk6jgdyd7mrdh9k4lm"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; Tests are implemented in GitHub Actions and require aditional
+ ;; packaging, see
+ ;; <https://github.com/pion/.goassets/blob/master/.github/workflows/test.reusable.yml>.
+ #:tests? #f
+ #:go go-1.21
+ #:import-path "github.com/pion/mdns"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-pion-logging
+ go-github-com-pion-transport-v3
+ go-golang-org-x-net))
+ (home-page "https://github.com/pion/mdns/")
+ (synopsis "Pure Go implementation of Multicast DNS")
+ (description
+ "This package implements a mDNS (multicast DNS) used by
+@url{https://github.com/pion, Pion}.")
+ (license license:expat)))
+
(define-public go-github-com-pion-rtp
(package
(name "go-github-com-pion-rtp")