summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 15:54:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:03 +0200
commitf2b4b2e1cca2d8f17f301db5f56ee552e4223d06 (patch)
tree64cb800052939e0a255931a85aa3af58bbfd68a7 /gnu
parentc78945b85ec30418bd7435351c85843b20421a87 (diff)
gnu: Add texlive-unisugar.
* gnu/packages/tex.scm (texlive-unisugar): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 947ecf2318..edc76985af 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7236,6 +7236,27 @@ RTL script without any markup.")
It only works with the XeTeX engine.")
(license license:lppl1.3c)))
+(define-public texlive-unisugar
+ (package
+ (name "texlive-unisugar")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/xelatex/unisugar/"
+ "tex/xelatex/unisugar/")
+ (base32
+ "1bn88ghfn14am1grph1pjw9k0xy1rz8swzhsbxsxyzz6cqk9s161")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/unisugar")
+ (synopsis "Define syntactic sugar for Unicode LaTeX")
+ (description
+ "The package allows the user to define shorthand aliases for single
+Unicode characters, and also provides support for such aliases in RTL-text.
+The package requires an TeX-alike system that uses Unicode input in a native
+way: current examples are XeTeX and LuaTeX.")
+ (license license:lppl1.3+)))
+
(define-public texlive-currfile
(package
(name "texlive-currfile")