summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:58:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:26 +0200
commitf3c0d2f8606779c655b655e453b427d0714d6c2f (patch)
treeb4b88234cfcf31268aa4b4976743b75d511af4c7 /gnu
parentbe4964964e6ea02124f547f115542002acfadec6 (diff)
gnu: Add texlive-luapackageloader.
* gnu/packages/tex.scm (texlive-luapackageloader): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2c83ad62e4..c9f8fe2a35 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16743,6 +16743,27 @@ it can be used to simply handle the parsing of optional @samp{key=value}
arguments into proper Lua tables.")
(license license:expat)))
+(define-public texlive-luapackageloader
+ (package
+ (name "texlive-luapackageloader")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/luapackageloader/"
+ "tex/luatex/luapackageloader/")
+ (base32
+ "0cf2p4zhfvf7f10pbpp332chj46ajknqgb7a8i16v63ivvmgb8m3")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-iftex))
+ (home-page "https://ctan.org/pkg/luapackageloader")
+ (synopsis "Allow LuaTeX to load external Lua packages")
+ (description
+ "This package allows LuaTeX to load packages from the default
+@code{package.path} and @code{package.cpath} locations. This could be useful
+to load external Lua modules, including modules installed via LuaRocks.")
+ (license license:lppl1.3c)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")