summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-30 23:47:43 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:35:40 +0300
commitf5907db6eb4c17b6d6c92edd1e95a40aae831dc3 (patch)
tree4b1a61d6c7673b5cd61e0283cb58b7c23117a60c /gnu
parent14d87c382765d832ee526108e56c69750f77728c (diff)
gnu: rust-rustix-0.37: Remove precompiled files.
* gnu/packages/crates-io.scm (rust-rustix-0.37)[source]: Add snippet to remove precompiled files and to not require them while building the package. (rust-rustix-0.36, rust-rustix-0.35): Inherit changes from rust-rustix-0.37.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9e8f66602c..8bc27c9eec 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56869,7 +56869,24 @@ rustc compiler.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0gb12rp992bh2h5msqcbpdsx6h1gslsb0zpp5hdnyxj2hnfp5y5c"))))
+ "0gb12rp992bh2h5msqcbpdsx6h1gslsb0zpp5hdnyxj2hnfp5y5c"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (for-each delete-file (find-files "." "\\.a$"))
+ (delete-file "Cargo.toml")
+ (substitute* "Cargo.toml.orig"
+ ;; Depend unconditionally on the cc crate
+ (("(cc = .*), optional = true.*" _ cc)
+ (string-append cc " }\n"))
+ ;; Disable using the linux_raw backend
+ (("not\\(rustic_use_libc\\)") "miri"))
+ (substitute* "build.rs"
+ ;; Always use the 'feature = "cc"' path
+ (("not\\(feature = \"cc\"\\)") "feature = \"foobar\"")
+ (("#\\[cfg\\(feature = \"cc\"\\)\\]" all)
+ (string-append "//" all)))
+ (copy-file "Cargo.toml.orig" "Cargo.toml")))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -56908,6 +56925,7 @@ rustc compiler.")
(name "rust-rustix")
(version "0.36.13")
(source (origin
+ (inherit (package-source rust-rustix-0.37))
(method url-fetch)
(uri (crate-uri "rustix" version))
(file-name (string-append name "-" version ".tar.gz"))
@@ -56945,6 +56963,7 @@ rustc compiler.")
(name "rust-rustix")
(version "0.35.13")
(source (origin
+ (inherit (package-source rust-rustix-0.36))
(method url-fetch)
(uri (crate-uri "rustix" version))
(file-name (string-append name "-" version ".tar.gz"))