summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2024-01-05 12:36:17 +0100
committerLudovic Courtès <ludo@gnu.org>2024-01-14 23:00:04 +0100
commitf6afaf58b0a0b04e5023141c8f56c204f9779e19 (patch)
treefdb2497b6036f3a122fcd1153e90c03f45298ebd /gnu
parent68f04aa339be1263f607b4eede5a71f25e4f7e46 (diff)
gnu: fish-foreign-env: Update to 0.20230823.
* gnu/packages/shells.scm (fish-foreign-env): Update to 0.20230823. [arguments]: Do no substitute in file that no longer exists. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Change-Id: I04138c1d3e8c174b2197e5ca60aaca4caa5453cc
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shells.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 8d2aadc0aa..e3de0eb205 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 David Pflug <david@pflug.io>
+;;; Copyright © 2024 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -273,16 +274,16 @@ and syntax highlighting.")
(define-public fish-foreign-env
(package
(name "fish-foreign-env")
- (version "0.20190116")
+ (version "0.20230823")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/oh-my-fish/plugin-foreign-env")
- (commit "dddd9213272a0ab848d474d0cbde12ad034e65bc")))
+ (commit "7f0cf099ae1e1e4ab38f46350ed6757d54471de7")))
(file-name (git-file-name name version))
(sha256
- (base32 "00xqlyl3lffc5l0viin1nyp819wf81fncqyz87jx8ljjdhilmgbs"))))
+ (base32 "0d16mdgjdwln41zk44qa5vcilmlia4w15r8z2rc3p49i5ankksg3"))))
(build-system trivial-build-system)
(arguments
'(#:modules ((guix build utils))
@@ -298,7 +299,6 @@ and syntax highlighting.")
;; Embed absolute paths.
(substitute* `(,(string-append func-path "/fenv.fish")
- ,(string-append func-path "/fenv.apply.fish")
,(string-append func-path "/fenv.main.fish"))
(("bash")
(search-input-file %build-inputs "/bin/bash"))