summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:02:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:16 +0200
commitf7326e24e9454d1c63a6e89a8a4df1bf59c56187 (patch)
tree03839de39226db08ecfc71dcdba7216119f1a13e /gnu
parent447effb6f2e86d5860a07209fe94bf0d1499ad9a (diff)
gnu: Add texlive-ucbthesis.
* gnu/packages/tex.scm (texlive-ucbthesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 81b5f8db67..b7d76c652a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -30512,6 +30512,26 @@ according to the thesis guidelines of the University of Calgary Faculty of
Graduate Studies. It uses the @code{memoir} class.")
(license license:expat)))
+(define-public texlive-ucbthesis
+ (package
+ (name "texlive-ucbthesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ucbthesis/"
+ "tex/latex/ucbthesis/")
+ (base32
+ "0kwy84r7vz5nvq8nrar1ykik4ycpvgl1kwiyi0da6wjn4cazxxh9")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ucbthesis")
+ (synopsis "Thesis and dissertation class supporting UCB requirements")
+ (description
+ "The class provides the necessary framework for electronic submission
+of masters theses and PhD dissertations at the University of
+California, Berkeley. It is based on the @code{memoir} class.")
+ (license license:lppl1.3+)))
+
(define-public texlive-ulqda
(package
(name "texlive-ulqda")