summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:27:45 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:04 +0000
commitf7ca047b6dd6f7d43a927f1b189be7a3a4e04581 (patch)
tree674b1b1690328e689e29004cd035a0102dcac424 /gnu
parentea912634de767da0c3d890082c0b652d3a5fd1a3 (diff)
gnu: go-github-com-jcmturner-aescts-v2: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-jcmturner-aescts-v2): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/golang-web.scm: Add (gnu packages golang-crypto) to used modules. Change-Id: Ie8f74e09ae50db4e4b0c9292d049cc46c033d6a6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-crypto.scm25
-rw-r--r--gnu/packages/golang-web.scm1
-rw-r--r--gnu/packages/golang.scm24
3 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index eac4fc8139..860ee82727 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
-;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022, 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;;
@@ -115,6 +115,29 @@ providing bidirectional mapping values to their names, plus enum convenience
for values.")
(license license:bsd-3)))
+(define-public go-github-com-jcmturner-aescts-v2
+ (package
+ (name "go-github-com-jcmturner-aescts-v2")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jcmturner/aescts")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0yrdiisdhcqfs8jpicc30dfmbqzxhkmbayn902xrgwkndky8w7l1"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jcmturner/aescts/v2"))
+ (propagated-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/jcmturner/aescts")
+ (synopsis "Encrypt and decrypt data in Go using AES CipherText Stealing")
+ (description "This package provides AES Cipher Block Chaining CipherText
+Stealing encryption and decryption methods.")
+ (license license:asl2.0)))
+
(define-public go-github-com-libp2p-go-libp2p-crypto
(let ((commit "7240b40a3ddc47c4d17c15baabcbe45e5219171b")
(revision "0"))
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 07b77ee673..dfa1f862dc 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -47,6 +47,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-check)
+ #:use-module (gnu packages golang-crypto)
#:use-module (gnu packages tls)
#:use-module (gnu packages web))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d2e2a07b74..a44427e5d4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1477,30 +1477,6 @@ not included in the Go standard library.")
"Package reqtrace contains a very simple request tracing framework.")
(license license:asl2.0))))
-(define-public go-github-com-jcmturner-aescts-v2
- (package
- (name "go-github-com-jcmturner-aescts-v2")
- (version "2.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jcmturner/aescts")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0yrdiisdhcqfs8jpicc30dfmbqzxhkmbayn902xrgwkndky8w7l1"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/jcmturner/aescts/v2"))
- (propagated-inputs (list go-github-com-stretchr-testify))
- (home-page "https://github.com/jcmturner/aescts")
- (synopsis "Encrypt and decrypt data in Go using AES CipherText Stealing")
- (description
- "This package provides AES Cipher Block Chaining CipherText Stealing
-encryption and decryption methods.")
- (license license:asl2.0)))
-
(define-public go-github-com-jcmturner-gofork
(package
(name "go-github-com-jcmturner-gofork")