summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-01 22:43:58 +0200
committerMarius Bakke <marius@gnu.org>2022-09-01 23:37:12 +0200
commitf807d1795fbdc7e3c9e63df36114f332e6f7f304 (patch)
treeb7b9735c8cc5806dd27c6d004e43cdbd8b3092d4 /gnu
parent648f3d5d4934bf7545e840377df4f3fc1ead6b41 (diff)
gnu: cURL: Update to 7.85.0.
* gnu/packages/curl.scm (curl): Update to 7.85.0. [source](patches): Remove obsolete. [arguments]: Remove obsolete phase. * gnu/packages/patches/curl-easy-lock.patch, gnu/packages/patches/curl-nghttp2-compat.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/curl.scm14
-rw-r--r--gnu/packages/patches/curl-easy-lock.patch31
-rw-r--r--gnu/packages/patches/curl-nghttp2-compat.patch141
4 files changed, 3 insertions, 185 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index fea12cd889..dabd3cf0b4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -988,8 +988,6 @@ dist_patch_DATA = \
%D%/packages/patches/crda-optional-gcrypt.patch \
%D%/packages/patches/clucene-contribs-lib.patch \
%D%/packages/patches/cube-nocheck.patch \
- %D%/packages/patches/curl-easy-lock.patch \
- %D%/packages/patches/curl-nghttp2-compat.patch \
%D%/packages/patches/curl-use-ssl-cert-env.patch \
%D%/packages/patches/cursynth-wave-rand.patch \
%D%/packages/patches/cvs-CVE-2017-12836.patch \
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 600163bf72..c91e268ef5 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -63,17 +63,15 @@
(define-public curl
(package
(name "curl")
- (version "7.84.0")
+ (version "7.85.0")
(source (origin
(method url-fetch)
(uri (string-append "https://curl.se/download/curl-"
version ".tar.xz"))
(sha256
(base32
- "1f2xgj0wvys9xw50h7vcbaraavjr9rxx9n06x2xfbgs7ym1qn49d"))
- (patches (search-patches "curl-use-ssl-cert-env.patch"
- "curl-nghttp2-compat.patch"
- "curl-easy-lock.patch"))))
+ "1rjbn0h5rddclhvxb8p5gddxszcrpbf5cw1whx6wnj4s9dnlmdc8"))
+ (patches (search-patches "curl-use-ssl-cert-env.patch"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
@@ -105,12 +103,6 @@
"--disable-static")
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'tweak-lib3026-test
- (lambda _
- ;; Have that test create a hundred threads, not a thousand.
- (substitute* "tests/libtest/lib3026.c"
- (("NUM_THREADS .*$")
- "NUM_THREADS 100\n"))))
(add-after 'unpack 'do-not-record-configure-flags
(lambda _
;; Do not save the configure options to avoid unnecessary references.
diff --git a/gnu/packages/patches/curl-easy-lock.patch b/gnu/packages/patches/curl-easy-lock.patch
deleted file mode 100644
index 137106f57c..0000000000
--- a/gnu/packages/patches/curl-easy-lock.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-This patch is taken from upstream master, and should probably be dropped
-with the next release.
-
-ihttps://github.com/curl/curl/commit/e2e7f54b7bea521fa8373095d0f43261a720cda0.patch
-
-From e2e7f54b7bea521fa8373095d0f43261a720cda0 Mon Sep 17 00:00:00 2001
-From: Daniel Stenberg <daniel@haxx.se>
-Date: Mon, 27 Jun 2022 08:46:21 +0200
-Subject: [PATCH] easy_lock.h: include sched.h if available to fix build
-
-Patched-by: Harry Sintonen
-
-Closes #9054
----
- lib/easy_lock.h | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/lib/easy_lock.h b/lib/easy_lock.h
-index 819f50ce815b8..1f54289ceb2d3 100644
---- a/lib/easy_lock.h
-+++ b/lib/easy_lock.h
-@@ -36,6 +36,9 @@
-
- #elif defined (HAVE_ATOMIC)
- #include <stdatomic.h>
-+#if defined(HAVE_SCHED_YIELD)
-+#include <sched.h>
-+#endif
-
- #define curl_simple_lock atomic_bool
- #define CURL_SIMPLE_LOCK_INIT false
diff --git a/gnu/packages/patches/curl-nghttp2-compat.patch b/gnu/packages/patches/curl-nghttp2-compat.patch
deleted file mode 100644
index e3f69c6010..0000000000
--- a/gnu/packages/patches/curl-nghttp2-compat.patch
+++ /dev/null
@@ -1,141 +0,0 @@
-Use CRLF headers in test responses to cope with newer nghttp2.
-
-Taken from upstream:
-
- https://github.com/curl/curl/commit/ef121401d6eabed204a716f16b2776ededc75c0e
-
-diff --git a/tests/data/test1700 b/tests/data/test1700
-index 8b1ef4ae336c3..7f78bcf5f92ed 100644
---- a/tests/data/test1700
-+++ b/tests/data/test1700
-@@ -11,26 +11,26 @@ HTTP/2
- # Server-side
- <reply>
- <data nocheck="yes">
--HTTP/1.1 200 OK
--Date: Tue, 09 Nov 2010 14:49:00 GMT
--Server: test-server/fake
--Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
--ETag: "21025-dc7-39462498"
--Accept-Ranges: bytes
--Content-Length: 6
--Connection: close
--Content-Type: text/html
--Funny-head: yesyes
--
-+HTTP/1.1 200 OK
-+Date: Tue, 09 Nov 2010 14:49:00 GMT
-+Server: test-server/fake
-+Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
-+ETag: "21025-dc7-39462498"
-+Accept-Ranges: bytes
-+Content-Length: 6
-+Connection: close
-+Content-Type: text/html
-+Funny-head: yesyes
-+
- -foo-
- </data>
- <data1>
--HTTP/1.1 200 OK
--Date: Tue, 09 Nov 2010 14:49:00 GMT
--Content-Length: 6
--Connection: close
--Content-Type: text/html
--
-+HTTP/1.1 200 OK
-+Date: Tue, 09 Nov 2010 14:49:00 GMT
-+Content-Length: 6
-+Connection: close
-+Content-Type: text/html
-+
- -maa-
- </data1>
- </reply>
-diff --git a/tests/data/test1701 b/tests/data/test1701
-index 3c1a2bd0b8217..22f6147d0503a 100644
---- a/tests/data/test1701
-+++ b/tests/data/test1701
-@@ -11,17 +11,17 @@ HTTP/2
- # Server-side
- <reply>
- <data nocheck="yes">
--HTTP/1.1 200 OK
--Date: Tue, 09 Nov 2010 14:49:00 GMT
--Server: test-server/fake
--Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
--ETag: "21025-dc7-39462498"
--Accept-Ranges: bytes
--Content-Length: 6
--Connection: close
--Content-Type: text/html
--Funny-head: yesyes
--
-+HTTP/1.1 200 OK
-+Date: Tue, 09 Nov 2010 14:49:00 GMT
-+Server: test-server/fake
-+Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
-+ETag: "21025-dc7-39462498"
-+Accept-Ranges: bytes
-+Content-Length: 6
-+Connection: close
-+Content-Type: text/html
-+Funny-head: yesyes
-+
- -foo-
- </data>
- </reply>
-diff --git a/tests/data/test358 b/tests/data/test358
-index 8b4f6606247a0..0f8a9801bbcb5 100644
---- a/tests/data/test358
-+++ b/tests/data/test358
-@@ -12,14 +12,14 @@ HTTP/2
- # Server-side
- <reply>
- <data nocheck="yes">
--HTTP/1.1 200 OK
--Date: Tue, 09 Nov 2010 14:49:00 GMT
--Content-Length: 6
--Connection: close
--Content-Type: text/html
--Funny-head: yesyes
--Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
--
-+HTTP/1.1 200 OK
-+Date: Tue, 09 Nov 2010 14:49:00 GMT
-+Content-Length: 6
-+Connection: close
-+Content-Type: text/html
-+Funny-head: yesyes
-+Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
-+
- -foo-
- </data>
- </reply>
-diff --git a/tests/data/test359 b/tests/data/test359
-index a5ba4e3ae0971..0e684e39e5aa5 100644
---- a/tests/data/test359
-+++ b/tests/data/test359
-@@ -12,14 +12,14 @@ HTTP/2
- # Server-side
- <reply>
- <data nocheck="yes">
--HTTP/1.1 200 OK
--Date: Tue, 09 Nov 2010 14:49:00 GMT
--Content-Length: 6
--Connection: close
--Content-Type: text/html
--Funny-head: yesyes
--Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
--
-+HTTP/1.1 200 OK
-+Date: Tue, 09 Nov 2010 14:49:00 GMT
-+Content-Length: 6
-+Connection: close
-+Content-Type: text/html
-+Funny-head: yesyes
-+Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
-+
- -foo-
- </data>
- </reply>