summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-05 10:22:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 21:33:32 +0300
commitf8cf3982ff37ca229c9f7928c778ea1fa115416a (patch)
tree88893919f35425e241e006c62b56c72ae753b0f3 /gnu
parent786d8fd60d33ec57689038f08092d134dbeb4be7 (diff)
gnu: Add tuba.
* gnu/packages/mastodon.scm (tuba): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mastodon.scm50
1 files changed, 49 insertions, 1 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index 9c1d3cd26f..6510d96e2d 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -32,12 +32,14 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
- #:use-module (gnu packages time))
+ #:use-module (gnu packages time)
+ #:use-module (gnu packages xml))
(define-public toot
(package
@@ -81,6 +83,52 @@ Features include:
@end itemize")
(license license:gpl3)))
+(define-public tuba
+ (package
+ (name "tuba")
+ (version "0.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GeopJr/Tuba")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xhyz6wi17g4m76lr6qc75q4xnnw7c3dh3d04dg8m5gzk6j0y89x"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:configure-flags (list "-Ddistro=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'glib-or-gtk-wrap 'symlink-package
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion
+ (string-append (assoc-ref outputs "out") "/bin")
+ (symlink "dev.geopjr.Tuba" "tuba")))))))
+ (native-inputs
+ (list gettext-minimal
+ `(,glib "bin") ; for glib-compile-resources
+ pkg-config))
+ (inputs
+ (list gtk
+ gtksourceview
+ json-glib
+ libadwaita
+ libgee
+ libsoup-minimal
+ libsecret
+ libwebp
+ libxml2
+ vala))
+ (home-page "https://tuba.geopjr.dev/")
+ (synopsis "GTK client for Mastodon")
+ (description "Tuba is a GTK client for Mastodon. It provides a clean,
+native interface that allows you to integrate Mastodon's social experience
+seamlessly with your desktop environment.")
+ (license license:gpl3)))
+
(define-public tootle
(package
(name "tootle")