summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2022-10-20 09:25:11 -0300
committerLudovic Courtès <ludo@gnu.org>2022-11-18 15:44:39 +0100
commitfc2b9522057681330d3b507aa69c9aa3b3b8f3e6 (patch)
treebafb2130839238d052356e241d63d1537a07edb5 /gnu
parentfd5e642513ea08cc9ba3b4197bcbf0b8d37ae966 (diff)
gnu: Add wld.
* gnu/packages/wm.scm (wld): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 6bca36f432..cf0dc63a38 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2953,3 +2954,36 @@ used for multimedia keys.")
an interface over @code{grim}, @code{slurp} and @code{jq}, and supports storing
the screenshot either directly to the clipboard using @code{wl-copy} or to a
file.")))
+
+(define-public wld
+ (let ((commit "6586736176ef50a88025abae835e29a7ca980126")
+ (revision "1"))
+ (package
+ (name "wld")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/michaelforney/wld")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qkd3q8p1s72x688g83fkcarrz2h20904rpd8z44ql6ksgrj9bp3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list fontconfig
+ libdrm
+ pixman
+ wayland))
+ (propagated-inputs (list fontconfig pixman))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/michaelforney/wld")
+ (synopsis "Primitive drawing library for Wayland")
+ (description "wld is a drawing library that targets Wayland.")
+ (license license:expat))))