summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-05 14:19:20 +0200
committerMarius Bakke <marius@gnu.org>2022-09-08 21:40:00 +0200
commitfc64753bd31a88c546baca0077c40f6cbf68c5fe (patch)
tree1332e9d34fd9120f36838b046c139c3f734745f1 /gnu
parentc37a31e9abbc54d284096e4684f6dc2e094dbd7d (diff)
gnu: doxygen: Update to 1.9.5.
* gnu/packages/documentation.scm (doxygen): Update to 1.9.5. [source](patches): Remove. * gnu/packages/patches/doxygen-support-gcc-12.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/documentation.scm6
-rw-r--r--gnu/packages/patches/doxygen-support-gcc-12.patch15
3 files changed, 2 insertions, 20 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 017e083fb0..a74c714475 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1014,7 +1014,6 @@ dist_patch_DATA = \
%D%/packages/patches/doc++-include-directives.patch \
%D%/packages/patches/doc++-segfault-fix.patch \
%D%/packages/patches/dovecot-trees-support-dovecot-2.3.patch \
- %D%/packages/patches/doxygen-support-gcc-12.patch \
%D%/packages/patches/dstat-fix-crash-when-specifying-delay.patch \
%D%/packages/patches/dstat-skip-devices-without-io.patch \
%D%/packages/patches/dvd+rw-tools-add-include.patch \
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 180b556cbf..e002905fb7 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -187,7 +187,7 @@ markup) can be customized and extended by the user.")
(define-public doxygen
(package
(name "doxygen")
- (version "1.9.4")
+ (version "1.9.5")
(home-page "https://www.doxygen.nl/")
(source (origin
(method url-fetch)
@@ -198,9 +198,7 @@ markup) can be customized and extended by the user.")
".src.tar.gz")))
(sha256
(base32
- "0dqzgci82z950pzg6cpxvvqwybi2031flml3pj47hayhq3c9qpm1"))
- ;; Remove with next release.
- (patches (search-patches "doxygen-support-gcc-12.patch"))))
+ "1v1f9cp5lyymg7xmw0ldnzi7ql8agbaqam1xdyljk0lrbnrm9d2m"))))
(build-system cmake-build-system)
(native-inputs
(list bison
diff --git a/gnu/packages/patches/doxygen-support-gcc-12.patch b/gnu/packages/patches/doxygen-support-gcc-12.patch
deleted file mode 100644
index 01f5040dde..0000000000
--- a/gnu/packages/patches/doxygen-support-gcc-12.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Fix for https://github.com/doxygen/doxygen/issues/9312 made in unreleased upstream commit
-https://github.com/doxygen/doxygen/commit/5198966c8d5fec89116d025c74934ac03ea511fa
-
-diff --git a/src/cache.h b/src/cache.h
-index 0ff3092ed5..e218eb27d2 100644
---- a/src/cache.h
-+++ b/src/cache.h
-@@ -19,6 +19,7 @@
- #include <list>
- #include <unordered_map>
- #include <mutex>
-+#include <utility>
- #include <ctype.h>
-
- /*! Fixed size cache for value type V using keys of type K.