summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:26:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:40 +0200
commitfd70a7e750d1f71d2bdb6b78eea608e4375ab73c (patch)
treee7ddd4769880e9a6472f420f6e66249fc081e053 /gnu
parent271a4102e355ce82c1c6aca8baf88632ebee2311 (diff)
gnu: Add texlive-pst-node.
* gnu/packages/tex.scm (texlive-pst-node): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index db9d091fa9..b02e7a1773 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33533,6 +33533,29 @@ drawing images as if reflected by a spherical mirror.")
(description "This is a PSTricks package to draw moiré patterns.")
(license license:lppl1.3c)))
+(define-public texlive-pst-node
+ (package
+ (name "texlive-pst-node")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-node/" "dvips/pst-node/"
+ "tex/generic/pst-node/"
+ "tex/latex/pst-node/")
+ (base32
+ "0w9j1l5hlid98sp6hm7ny0z3nh6jcccvxglprq0wr08w89zb7dmz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-node")
+ (synopsis "Nodes and node connections in PSTricks")
+ (description
+ "The package enables the user to connect information, and to place labels,
+without knowing (in advance) the actual positions of the items to be
+connected, or where the connecting line should go. The macros are useful for
+making graphs and trees, mathematical diagrams, linguistic syntax diagrams,
+and so on.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")