summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 13:08:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 13:08:02 +0200
commitff6b2a88c4600ad5774e6dde9eb7e2c18e85ada3 (patch)
treecf8160065dc04e10cbd9183d74714cb603373421 /gnu
parentb2750695f72519286cb0530431396767588cc67d (diff)
gnu: Add r-gwasexacthw.
* gnu/packages/cran.scm (r-gwasexacthw): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bc2f7acb7f..acd1eb0be5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -926,6 +926,27 @@ differential abundance analysis of zero-inflated high-dimensional
compositional data.")
(license license:gpl3)))
+(define-public r-gwasexacthw
+ (package
+ (name "r-gwasexacthw")
+ (version "1.01")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "GWASExactHW" version))
+ (sha256
+ (base32
+ "19qmk8h7kxmn9kzw0x4xns5p3qqz27xkqq4q6zmh4jzizd0fsl78"))))
+ (properties `((upstream-name . "GWASExactHW")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/package=GWASExactHW")
+ (synopsis
+ "Exact Hardy-Weinburg testing for Genome Wide Association Studies")
+ (description
+ "This package contains a function to do exact Hardy-Weinburg
+testing (using Fisher's test) for SNP genotypes as typically obtained in a
+@dfn{Genome Wide Association Study} (GWAS).")
+ (license license:gpl3)))
+
(define-public r-gwidgets2
(package
(name "r-gwidgets2")