summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/geo.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 97fa83b86b..8c98534a4a 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -442,9 +442,8 @@ writing GeoTIFF information tags.")
("librttopo" ,librttopo)
("libxml2" ,libxml2)
("minizip" ,minizip)
- ("proj.4" ,proj.4)
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
+ ("proj" ,proj)
+ ("sqlite" ,sqlite)))
(arguments
`(#:configure-flags
'("--enable-rttopo=yes")
@@ -454,7 +453,7 @@ writing GeoTIFF information tags.")
(add-after 'unpack 'ignore-broken-tests
(lambda _
(substitute* '("test/Makefile.in")
- (("\tcheck_sql_stm.*" all) "\tcheck_multithread$(EXEEXT) \\\n")
+ (("\tcheck_sql_stmt.* (check_sql_.*)" all tiny) (string-append "\t" tiny))
(("(\tch.*) check_v.*ble2.*$" all vt1) (string-append vt1 " \\\n"))
(("\tch.* (check_v.*ble4.*)$" all vt4) (string-append "\t" vt4)))
#t)))))
@@ -1748,10 +1747,9 @@ associated attribute file (@file{.dbf}).")
("libspatialite" ,libspatialite)
("libxml2" ,libxml2)
("minizip" ,minizip)
- ("proj.4" ,proj.4)
+ ("proj" ,proj)
("readosm" ,readosm)
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
+ ("sqlite" ,sqlite)))
(synopsis "Collection of command line tools for SpatiaLite")
(description
"@code{spatialite-tools} is a collection of Command Line Interface (CLI)