summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c78f017a24..b909cd5ee0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3787,6 +3787,13 @@ UCSC genome browser.")
"-xf" (assoc-ref inputs "test-data"))
;; This one requires bowtie-build
(delete-file "plastid/test/functional/test_crossmap.py")))
+ (add-after 'unpack 'patch-for-python-3.10
+ (lambda _
+ ;; Some classes were moved from collections to collections.abc
+ ;; in Python 3.10.
+ (substitute* "plastid/readers/bigbed.pyx"
+ ((", Iterable")
+ "\nfrom collections.abc import Iterable"))))
(add-before 'check 'build-extensions
(lambda _
;; Cython extensions have to be built before running the tests.