summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell-xyz.scm3
-rw-r--r--gnu/packages/python-xyz.scm6
2 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 86af842980..f2cc60267b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8315,6 +8315,9 @@ provided for those who need a drop-in replacement for Markdown.pl.")
(name "pandoc")
(arguments
(list
+ ;; Create entirely self-contained binary by embedding the data files
+ ;; in the binary itself. Required for python-pypandoc.
+ #:configure-flags #~(list "-fembed_data_files")
#:phases
#~(modify-phases %standard-phases
(add-after 'register 'remove-libraries
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac10290237..9d086136d0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27787,17 +27787,17 @@ By default it uses the open Python vulnerability database Safety DB.")
(define-public python-pypandoc
(package
(name "python-pypandoc")
- (version "1.6.4")
+ (version "1.7.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pypandoc" version))
(sha256
(base32
- "149basv4pvzg9zm74cjz68x8s2n5fykyj7prgysb0qfmja73r83f"))))
+ "0l6a8ngzpx363q2jskxxkx6psfhqrvc4js80dmn16r3vw6m2cb40"))))
(build-system python-build-system)
(inputs
- (list pandoc))
+ (list pandoc python-pandocfilters))
(propagated-inputs
`(("wheel" ,python-wheel)))
(native-inputs