summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/c.scm29
-rw-r--r--gnu/packages/electronics.scm8
2 files changed, 15 insertions, 22 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 96b4e904f7..b12aaf184a 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1365,20 +1365,21 @@ will take care of dispatching tasks to available cores.")
"0x9f7ivww8c7cigf4ck0hfx2bm79qgx6q4ccwzqbzkrmcrl9shfb"))))
(build-system cmake-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'build)
- (delete 'configure)
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (with-directory-excursion "test"
- (invoke "cmake" ".")
- (invoke "make")))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (install-file "utf8.h" (string-append out "/include"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'build)
+ (delete 'configure)
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "test"
+ (invoke "cmake" ".")
+ (invoke "make")))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "utf8.h"
+ (string-append #$output "/include/utf8")))))))
(home-page "https://github.com/sheredom/utf8.h")
(synopsis "Single header UTF-8 string functions for C and C++")
(description "A simple one header solution to supporting UTF-8 strings in
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 8ca956df26..f0c65c53c7 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -298,14 +298,6 @@ supported devices, as well as input/output file format support.")
"add_subdirectory("
(search-input-directory inputs "share/glad") ;source_dir
" src/glad)\n"))))) ;binary dir
- (add-before 'configure 'fix-utf8-include-directive
- ;; Our utf8-h package makes the header available as "utf8.h"
- ;; directly rather than "utf8/utf8.h".
- (lambda _
- (substitute* '("src/openboardview/FileFormats/BRDFile.cpp"
- "src/openboardview/FileFormats/BRDFileBase.cpp"
- "src/openboardview/BoardView.cpp")
- (("utf8/utf8.h") "utf8.h"))))
(add-before 'configure 'dynamically-load-gtk-via-absolute-path
;; The GTK library is not linked thus not present in the RUNPATH of
;; the produced binary; the absolute path of the libraries must to