summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/mes.scm6
-rw-r--r--gnu/packages/patches/nyacc-binary-literals.patch29
3 files changed, 33 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1924ae9467..847e45e8cc 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -988,6 +988,7 @@ dist_patch_DATA = \
%D%/packages/patches/nvi-assume-preserve-path.patch \
%D%/packages/patches/nvi-dbpagesize-binpower.patch \
%D%/packages/patches/nvi-db4.patch \
+ %D%/packages/patches/nyacc-binary-literals.patch \
%D%/packages/patches/nyx-show-header-stats-with-python3.patch \
%D%/packages/patches/ocaml-bisect-fix-camlp4-in-another-directory.patch \
%D%/packages/patches/ocaml-bitstring-fix-configure.patch \
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 81d4145439..7bdad5e32f 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -39,15 +39,15 @@
(define-public nyacc
(package
(name "nyacc")
- (version "0.83.3")
+ (version "0.86.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/nyacc/"
name "-" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (patches (search-patches "nyacc-binary-literals.patch"))
(sha256
(base32
- "0120n0mdb6r58c4jc024dhwqy5s8a20waknijfhqjc59a884lrd6"))))
+ "0lkd9lyspvhxlfs0496gsllwinh62jk9wij6gpadvx9gwz6yavd9"))))
(build-system gnu-build-system)
(native-inputs
`(("guile" ,guile-2.2)))
diff --git a/gnu/packages/patches/nyacc-binary-literals.patch b/gnu/packages/patches/nyacc-binary-literals.patch
new file mode 100644
index 0000000000..8159d74032
--- /dev/null
+++ b/gnu/packages/patches/nyacc-binary-literals.patch
@@ -0,0 +1,29 @@
+From 6a08014b77bf435f025ecdac08396580b85f159a Mon Sep 17 00:00:00 2001
+From: Jan Nieuwenhuizen <janneke@gnu.org>
+Date: Sat, 8 Sep 2018 20:22:45 +0200
+Subject: [PATCH] fix binary literals.
+
+---
+ module/nyacc/lex.scm | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/module/nyacc/lex.scm b/module/nyacc/lex.scm
+index 2ec9895..b205212 100644
+--- a/module/nyacc/lex.scm
++++ b/module/nyacc/lex.scm
+@@ -345,10 +345,11 @@
+ ((char-numeric? ch) (iter chl '$fixed ba 1 ch))
+ ((char=? #\. ch) (iter (cons ch chl) #f ba 15 (read-char)))
+ (else #f)))
+- ((10) ;; allow x after 0
++ ((10) ;; allow x, b after 0
+ (cond
+ ((eof-object? ch) (iter chl ty ba 5 ch))
+ ((char=? #\x ch) (iter (cons ch chl) ty 16 1 (read-char)))
++ ((char=? #\b ch) (iter (cons ch chl) ty 2 1 (read-char)))
+ (else (iter chl ty ba 1 ch))))
+ ((15) ;; got `.' only
+ (cond
+--
+2.18.0
+