summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioconductor.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 9d924c5429..f6917405a3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -20025,6 +20025,41 @@ segmented data for individual and multiple arrays.")
;; Expanded from GPL
(license (list license:gpl2+ license:gpl3+))))
+(define-public r-snprelate
+ (package
+ (name "r-snprelate")
+ (version "1.34.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "SNPRelate" version))
+ (sha256
+ (base32
+ "0js932qvhlwmnrr2jfvsch2zm6w6a1z5wydns3r1bw24r817dlgh"))))
+ (properties `((upstream-name . "SNPRelate")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-gdsfmt))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/zhengxwen/SNPRelate")
+ (synopsis
+ "Toolset for relatedness and Principal Component Analysis of SNP data")
+ (description
+ "Genome-wide association studies (GWAS) are widely used to investigate
+the genetic basis of diseases and traits, but they pose many computational
+challenges. The R package SNPRelate provides a binary format for
+single-nucleotide polymorphism (SNP) data in GWAS utilizing CoreArray Genomic
+Data Structure (GDS) data files. The GDS format offers the efficient
+operations specifically designed for integers with two bits, since a SNP could
+occupy only two bits. SNPRelate is also designed to accelerate two key
+computations on SNP data using parallel computing for multi-core symmetric
+multiprocessing computer architectures: Principal Component Analysis (PCA) and
+relatedness analysis using Identity-By-Descent measures. The SNP GDS format
+is also used by the GWASTools package with the support of S4 classes and
+generic functions. The extended GDS format is implemented in the SeqArray
+package to support the storage of single nucleotide variations (SNVs),
+insertion/deletion polymorphism (indel) and structural variation calls in
+whole-genome and whole-exome variant data.")
+ (license license:gpl3)))
+
(define-public r-snpstats
(package
(name "r-snpstats")