summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/textutils.scm27
-rw-r--r--gnu/packages/video.scm5
3 files changed, 19 insertions, 15 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 453d742fb1..894a21698e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5579,7 +5579,7 @@ in-window at 640x480 resolution or fullscreen.")
(lambda _
(substitute* "lib/framework/wzstring.cpp"
(("<utfcpp/source/utf8.h>")
- "<utf8.h>"))))
+ "<utf8cpp/utf8.h>"))))
(add-after 'unpack 'link-tests-with-qt
(lambda _
(substitute* "tests/Makefile.am"
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 2eb0f0986f..65672cb0cc 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -25,6 +25,8 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2022 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -690,29 +692,26 @@ spreadsheets and outputs it in comma-separated-value format, and
(define-public utfcpp
(package
(name "utfcpp")
- (version "2.3.5")
+ (version "3.2.4")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/nemtrif/utfcpp")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ ;; Unbundle ftest
+ (snippet
+ '(begin
+ (delete-file-recursively "extern")
+ (substitute* (find-files "tests" "\\.cpp")
+ (("\"../extern/ftest/ftest.h\"")
+ "<ftest/ftest.h>"))))
(sha256
(base32
- "1gr98d826z6wa58r1s5i7rz7q2x3r31v7zj0pjjlrc7gfxwklr4s"))))
+ "0p18cbdk57ilbgcgprgqp7fgysb5i0nidczbhc5rnxkiiw4jvxgn"))))
(build-system cmake-build-system)
- (arguments
- `(#:out-of-source? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'install ; no install target
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (include (string-append out "/include"))
- (doc (string-append out "/share/doc/" ,name)))
- (copy-recursively "source" include)
- (install-file "README.md" doc)
- #t))))))
+ (native-inputs (list ftest))
(home-page "https://github.com/nemtrif/utfcpp")
(synopsis "Portable C++ library for handling UTF-8")
(description "UTF8-CPP is a C++ library for handling UTF-8 encoded text
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 78202be471..cc52c1b850 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1057,6 +1057,11 @@ H.264 (MPEG-4 AVC) video streams.")
"--enable-precompiled-headers=no")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-utfcpp-include
+ (lambda _
+ (substitute* "src/common/strings/utf8.cpp"
+ (("<utf8.h>")
+ "<utf8cpp/utf8.h>"))))
(add-after 'unpack 'patch-relative-file-names
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))