summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 29812d48ef..98338cb701 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2439,7 +2439,16 @@ termination.")
"1k7xd2q2ysv2xsh373qs801v6f359240kx0vrl0ydh7731lngvk6"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/jtolds/gls"))
+ (list
+ #:import-path "github.com/jtolds/gls"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(synopsis "@code{gls} provides Goroutine local storage")
(description
"The @code{gls} package provides a way to store a retrieve values