summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2ed4c7a73c..bea58e9e31 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2485,6 +2485,32 @@ web framework
@end itemize")
(license license:expat)))
+(define-public go-github-com-nathan-osman-go-sunrise
+ (let ((commit "c8f9f1eb869135f07378e7e3c5ec7a005f806c73")
+ (revision "0"))
+ (package
+ (name "go-github-com-nathan-osman-go-sunrise")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nathan-osman/go-sunrise")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "017zwzx05r5spxcs07dp6bnh7waknzsd819k7aqd8kr819v3x9in"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/nathan-osman/go-sunrise"))
+ (home-page "https://github.com/nathan-osman/go-sunrise")
+ (synopsis "Calculate sunrise and sunset times in Go")
+ (description
+ "This package provides a Go library for calculating sunrise and
+sunset times from geographical coordinates and a date.")
+ (license license:expat))))
+
(define-public go-github-com-aws-sdk
(package
(name "go-github-com-aws-sdk")