summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm36
-rw-r--r--gnu/packages/mail.scm36
2 files changed, 37 insertions, 35 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d555a92579..70731e2720 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Chadwain Holness <chadwainholness@gmail.com>
+;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3036,41 +3037,6 @@ with the HTTP protocol definition.")
API service accounts for Go.")
(license license:asl2.0)))
-(define-public go-github-com-google-gmail-oauth2-tools-go-sendgmail
- (let ((commit "e3229155a4037267ce40f1a3a681f53221aa4d8d")
- (revision "0"))
- (package
- (name "go-github-com-google-gmail-oauth2-tools-go-sendgmail")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/gmail-oauth2-tools")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1cxpkiaajhq1gjsg47r2b5xgck0r63pvkyrkm7af8c8dw7fyn64f"))))
- (propagated-inputs
- `(("go-golang-org-x-oauth2" ,go-golang-org-x-oauth2)
- ("go-cloud-google-com-go-compute-metadata"
- ,go-cloud-google-com-go-compute-metadata)))
- (build-system go-build-system)
- (arguments
- '(#:unpack-path "github.com/google/gmail-oauth2-tools"
- #:import-path "github.com/google/gmail-oauth2-tools/go/sendgmail"))
- (home-page
- "https://github.com/google/gmail-oauth2-tools/tree/master/go/sendgmail")
- (synopsis
- "Sendmail-compatible tool for using Gmail with @code{git send-email}")
- (description
- "The @command{sendgmail} command provides a minimal sendmail-compatible
-front-end that connects to Gmail using OAuth2. It is specifically designed
-for use with @code{git send-email}. The command needs a Gmail API key to
-function.")
- (license license:asl2.0))))
-
(define-public go-github-com-google-cadvisor
(let ((commit "2ed7198f77395ee9a172878a0a7ab92ab59a2cfd")
(revision "0"))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 83ffb57645..b75c1a0965 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Benoit Joly <benoit@benoitj.ca>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4657,3 +4658,38 @@ feeds, converts them into emails, and sends them.")
;; GPL version 2 or 3. NOT 2+.
(license (list license:gpl2
license:gpl3))))
+
+(define-public sendgmail
+ (let ((commit "e3229155a4037267ce40f1a3a681f53221aa4d8d")
+ (revision "0"))
+ (package
+ (name "sendgmail")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gmail-oauth2-tools")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cxpkiaajhq1gjsg47r2b5xgck0r63pvkyrkm7af8c8dw7fyn64f"))))
+ (inputs
+ `(("go-golang-org-x-oauth2" ,go-golang-org-x-oauth2)
+ ("go-cloud-google-com-go-compute-metadata"
+ ,go-cloud-google-com-go-compute-metadata)))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/google/gmail-oauth2-tools"
+ #:import-path "github.com/google/gmail-oauth2-tools/go/sendgmail"))
+ (home-page
+ "https://github.com/google/gmail-oauth2-tools/tree/master/go/sendgmail")
+ (synopsis
+ "Sendmail-compatible tool for using Gmail with @code{git send-email}")
+ (description
+ "The @command{sendgmail} command provides a minimal sendmail-compatible
+front-end that connects to Gmail using OAuth2. It is specifically designed
+for use with @code{git send-email}. The command needs a Gmail API key to
+function.")
+ (license license:asl2.0))))