summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell-apps.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 2a07aa547d..8ef5bb5788 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -372,15 +372,15 @@ to @code{cabal repl}).")
(format out "main = buildMansOrWarn~%")))
(invoke "runhaskell" "Build/MakeMans.hs")))
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
;; We need to set the path so that Git recognizes
;; `git annex' as a custom command.
(setenv "PATH" (string-append (getenv "PATH") ":"
(getcwd) "/dist/build/git-annex"))
- (with-directory-excursion "dist/build/git-annex"
- (symlink "git-annex" "git-annex-shell"))
- (invoke "git-annex" "test")
- #t))
+ (when tests?
+ (with-directory-excursion "dist/build/git-annex"
+ (symlink "git-annex" "git-annex-shell"))
+ (invoke "git-annex" "test"))))
(add-after 'check 'unpatch-shell-and-rebuild
(lambda args
;; Undo `patch-shell-for-tests'.