summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/xiph.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 879d8e8d39..f3603c39bb 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages xml)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
@@ -117,7 +118,26 @@ polyphonic) audio and music at fixed and variable bitrates from 16 to
(patches (search-patches "libtheora-config-guess.patch"))))
(build-system gnu-build-system)
(arguments
- (list #:configure-flags #~'("--disable-static")))
+ (append
+ (if (and (target-riscv64?)
+ (%current-target-system))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'update-config
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub"))))))
+ '())
+ (list #:configure-flags #~'("--disable-static"))))
+ (native-inputs
+ (if (and (target-riscv64?)
+ (%current-target-system))
+ (list config)
+ '()))
(inputs (list libvorbis))
;; The .pc files refer to libogg.
(propagated-inputs (list libogg))