summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gtk.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 8e9a9dc8b2..c5ec7bcdc2 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -194,15 +195,21 @@ such as mate-panel and xfce4-panel.")
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))))
(native-inputs
- `(("gobject-introspection" ,gobject-introspection)
+ `(,@(if (target-hurd?)
+ '()
+ `(("gobject-introspection" ,gobject-introspection)))
("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs
`(("bash-minimal" ,bash-minimal) ;for glib-or-gtk-wrap
- ("drm" ,libdrm)
+ ,@(if (target-hurd?)
+ '()
+ `(("drm" ,libdrm)))
("ghostscript" ,ghostscript)
("libspectre" ,libspectre)
- ("poppler" ,poppler)))
+ ,@(if (target-hurd?)
+ '()
+ `(("poppler" ,poppler)))))
(propagated-inputs
`( ;; ("cogl" ,cogl)
;; ("directfb" ,directfb)