summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/chez.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index c3cb7d7659..5edce56505 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -100,6 +100,10 @@
'())))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-processor-detection
+ (lambda _ (substitute* "configure"
+ (("uname -a") "uname -m"))
+ #t))
;; Adapt the custom 'configure' script.
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)