summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/algebra.scm2
-rw-r--r--gnu/packages/maths.scm18
2 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index f82c839ed3..d60f53a7f9 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -410,7 +410,7 @@ precision.")
(inputs
;; TODO: Add libnauty, unbundle "libmicropython.a".
`(("fltk" ,fltk)
- ("glpk" ,glpk)
+ ("glpk" ,glpk-4)
("gmp" ,gmp)
("gsl" ,gsl)
("lapack" ,lapack)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c118e9e25c..794111afc4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -562,7 +562,7 @@ It can utilize SIMD instructions that are available on modern processors.")
(define-public glpk
(package
(name "glpk")
- (version "4.65")
+ (version "5.0")
(source
(origin
(method url-fetch)
@@ -570,7 +570,7 @@ It can utilize SIMD instructions that are available on modern processors.")
version ".tar.gz"))
(sha256
(base32
- "040sfaa9jclg2nqdh83w71sv9rc1sznpnfiripjdyr48cady50a2"))))
+ "05bgxidxj8d9xdp82niy7cy36w181cxq7p8vc3y2ixshpgp1642a"))))
(build-system gnu-build-system)
(inputs
`(("gmp" ,gmp)))
@@ -586,6 +586,20 @@ translator for the language. In addition to the C library, a stand-alone
LP/MIP solver is included in the package.")
(license license:gpl3+)))
+(define-public glpk-4
+ (package
+ (inherit glpk)
+ (name "glpk")
+ (version "4.65")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/glpk/glpk-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "040sfaa9jclg2nqdh83w71sv9rc1sznpnfiripjdyr48cady50a2"))))))
+
(define-public 4ti2
(package
(name "4ti2")