summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/yasm.scm55
2 files changed, 56 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 2600858fe0..a5000bcdfe 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -176,6 +176,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/xml.scm \
gnu/packages/xnee.scm \
gnu/packages/xorg.scm \
+ gnu/packages/yasm.scm \
gnu/packages/zile.scm \
gnu/packages/zip.scm \
gnu/system/vm.scm
diff --git a/gnu/packages/yasm.scm b/gnu/packages/yasm.scm
new file mode 100644
index 0000000000..51cd3ed0a5
--- /dev/null
+++ b/gnu/packages/yasm.scm
@@ -0,0 +1,55 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages yasm)
+ #:use-module (gnu packages)
+ #:use-module ((guix licenses)
+ #:renamer (symbol-prefix-proc 'license:))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages xml))
+
+(define-public yasm
+ (package
+ (name "yasm")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.tortall.net/projects/yasm/releases/yasm-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0cfg7ji3ia2in628w42wrfvw2ixmmm4rghwmv2k202mraysgm3vn"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("python" ,python)
+ ("xmlto" ,xmlto)))
+ (home-page "http://yasm.tortall.net/")
+ (synopsis "Rewrite of the NASM assembler")
+ (description
+ "Yasm is a complete rewrite of the NASM assembler.
+
+Yasm currently supports the x86 and AMD64 instruction sets, accepts NASM
+and GAS assembler syntaxes, outputs binary, ELF32, ELF64, 32 and 64-bit
+Mach-O, RDOFF2, COFF, Win32, and Win64 object formats, and generates source
+debugging information in STABS, DWARF 2, and CodeView 8 formats.")
+ (license (license:bsd-style "file://COPYING"
+ "See COPYING in the distribution."))))