summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/glib.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a9c7f4a81c..f0328498e4 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1097,7 +1097,11 @@ Some codes examples can be find at:
(lambda _
(substitute* "libappstream-glib/as-self-test.c"
(("g_test_add_func.*as_test_store_local_appdata_func);") ""))
- #t)))))
+ #t))
+ (add-before 'check 'set-home
+ (lambda _
+ ;; Some tests want write access there.
+ (setenv "HOME" "/tmp"))))))
(home-page "https://github.com/hughsie/appstream-glib")
(synopsis "Library for reading and writing AppStream metadata")
(description "This library provides objects and helper methods to help