summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/xf86-video-tga-remove-mibstore.patch34
-rw-r--r--gnu/packages/xorg.scm7
3 files changed, 39 insertions, 3 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 0493fa3483..448d938761 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -473,6 +473,7 @@ dist_patch_DATA = \
gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch \
gnu/packages/patches/xf86-video-sis-update-api.patch \
gnu/packages/patches/xf86-video-tdfx-remove-mibstore.patch \
+ gnu/packages/patches/xf86-video-tga-remove-mibstore.patch \
gnu/packages/patches/xfce4-panel-plugins.patch \
gnu/packages/patches/xmodmap-asprintf.patch
diff --git a/gnu/packages/patches/xf86-video-tga-remove-mibstore.patch b/gnu/packages/patches/xf86-video-tga-remove-mibstore.patch
new file mode 100644
index 0000000000..b1a96c3f10
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-tga-remove-mibstore.patch
@@ -0,0 +1,34 @@
+Removes references to mibstore.h and miInitializeBackingStore, which
+have been removed from xorg-server. Zack Rusin <zackr@vmware.com>
+wrote: "It was a noop for at least 5 years and it has been removed."
+See: http://patches.openembedded.org/patch/46133/
+
+--- xf86-video-tga-1.2.2/src/tga_accel.c.~1~ 2012-07-15 23:54:04.000000000 -0400
++++ xf86-video-tga-1.2.2/src/tga_accel.c 2014-12-19 01:40:27.535913013 -0500
+@@ -37,7 +37,6 @@
+ #include "xf86cmap.h"
+ #include "mipointer.h"
+
+-#include "mibstore.h"
+ #include "miline.h"
+
+ #include "tga_regs.h"
+--- xf86-video-tga-1.2.2/src/tga_driver.c.~1~ 2012-07-15 23:54:28.000000000 -0400
++++ xf86-video-tga-1.2.2/src/tga_driver.c 2014-12-19 01:40:48.756018238 -0500
+@@ -46,8 +46,6 @@
+
+ /* software cursor */
+ #include "mipointer.h"
+-/* backing store */
+-#include "mibstore.h"
+
+ /* #include "mibank.h" */
+ /* colormap manipulation */
+@@ -1451,7 +1449,6 @@
+
+ fbPictureInit (pScreen, 0, 0);
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+ xf86SetSilkenMouse(pScreen);
+
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6eca79935e..3f6c7b9639 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2972,17 +2972,18 @@ kernel mode setting (KMS).")
(define-public xf86-video-tga
(package
(name "xf86-video-tga")
- (version "1.2.1")
+ (version "1.2.2")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/X11R7.7/src/everything/xf86-video-tga-"
+ "mirror://xorg/individual/driver/xf86-video-tga-"
version
".tar.bz2"))
(sha256
(base32
- "0mdqrn02zzkdnmhg4vh9djaawg6b2p82g5qbj66z8b30yr77b93h"))))
+ "0cb161lvdgi6qnf1sfz722qn38q7kgakcvj7b45ba3i0020828r0"))
+ (patches (list (search-patch "xf86-video-tga-remove-mibstore.patch")))))
(build-system gnu-build-system)
(inputs `(("xf86dgaproto" ,xf86dgaproto)
("xorg-server" ,xorg-server)))