summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/networking.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f6c020864f..851940469d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2283,8 +2283,7 @@ libproxy only have to specify which proxy to use.")
line)))))
(add-before 'configure 'set-up-environment
(lambda _
- (setenv "CC" "gcc")
- #t)))))
+ (setenv "CC" ,(cc-for-target)))))))
(synopsis "Redirect any TCP connection through a proxy or proxy chain")
(description "Proxychains-ng is a preloader which hooks calls to sockets
in dynamically linked programs and redirects them through one or more SOCKS or