summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-frameworks.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6f261afd1a..78290cf1a9 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2747,13 +2747,26 @@ to easily extend the contacts collection.")
("solid" ,solid)
("threadweaver" ,threadweaver)))
(arguments
- `(#:tests? #f ; FIXME: 1/1 tests fail.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths-for-test
+ ;; This test tries to access paths like /home, /usr/bin and /bin/ls
+ ;; which don't exist in the build-container. Change to existing paths.
+ (lambda _
+ (substitute* "autotests/runnercontexttest.cpp"
+ (("/home\"") "/tmp\"") ;; single path-part
+ (("//usr/bin\"") (string-append (getcwd) "\"")) ;; multiple path-parts
+ (("/bin/ls" path)
+ (string-append (assoc-ref %build-inputs "coreutils") path)))))
(add-before 'check 'check-setup
(lambda _
+ (setenv "HOME" (getcwd))
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
+ ;; Blacklist a failing test-function. TODO: Make it pass.
+ (with-output-to-file "bin/BLACKLIST"
+ (lambda _
+ (display "[testMatch]\n*\n")))
#t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Framework for Plasma runners")