summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/guile.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 06ffc39f1d..64a1b900de 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -842,7 +842,20 @@ type system, elevating types to first-class status.")
(lambda _
(substitute* "Makefile.am"
((".*tests/blob\\.scm.*") ""))))))
- '())))
+ '())
+ ,@(if (system-hurd?)
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-tests/hurd
+ (lambda _
+ (substitute* "tests/proxy.scm"
+ (("\\(test-begin.*" all)
+ (string-append
+ all
+ "(when (string-ci= \"GNU\" (vector-ref (uname) 0))\n"
+ " (test-skip 1))\n")))))))
+ '())))
(native-inputs
(list pkg-config autoconf automake texinfo guile-3.0 guile-bytestructures))
(inputs