summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm24
-rw-r--r--gnu/packages/syncthing.scm22
-rw-r--r--gnu/packages/textutils.scm1
3 files changed, 24 insertions, 23 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9968bc9516..71303be53d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1202,6 +1202,30 @@ interfaces to back that API. Packages in the Go ecosystem can depend on it,
while callers can implement logging with whatever backend is appropriate.")
(license license:asl2.0)))
+(define-public go-github-com-gobwas-glob
+ (package
+ (name "go-github-com-gobwas-glob")
+ (version "0.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gobwas/glob")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jxk1x806zn5x86342s72dq2qy64ksb3zrvrlgir2avjhwb18n6z"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/gobwas/glob"))
+ (home-page "https://github.com/gobwas/glob")
+ (synopsis "Go globbing library")
+ (description
+ "This package provides a Go implementation of globs.")
+ (license license:expat)))
+
(define-public go-github-com-hashicorp-errwrap
(package
(name "go-github-com-hashicorp-errwrap")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 4d2f7ef9f0..3f8cb808ce 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -353,28 +353,6 @@ structs in the Go programming language.")
(home-page "https://github.com/d4l3k/messagediff")
(license expat)))
-(define-public go-github-com-gobwas-glob
- (package
- (name "go-github-com-gobwas-glob")
- (version "0.2.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gobwas/glob")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0jxk1x806zn5x86342s72dq2qy64ksb3zrvrlgir2avjhwb18n6z"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/gobwas/glob"))
- (synopsis "Go globbing library")
- (description "This package provides a Go implementation of globs.")
- (home-page "https://github.com/gobwas/glob")
- (license expat)))
-
-
(define-public go-github-com-golang-groupcache-lru
(let ((commit "869f871628b6baa9cfbc11732cdf6546b17c1298")
(revision "2"))
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 38452339c0..9d3b93faf9 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -85,7 +85,6 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
#:use-module (gnu packages slang)
- #:use-module (gnu packages syncthing)
#:use-module (gnu packages web)
#:use-module (gnu packages xorg))