summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/engineering.scm35
1 files changed, 17 insertions, 18 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index bdc4b179e1..828c13d376 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1499,25 +1499,24 @@ replacement for the OpenDWG libraries.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--enable-lock-dir=/var/lock")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-git-checkout-writable
- (lambda _
- (for-each make-file-writable (find-files "."))))
- (replace 'bootstrap
- ;; autogen.sh needlessly hard-codes aclocal-1.14.
- (lambda _
- (invoke "autoreconf" "-vif")))
- (add-before 'configure 'patch-lock-check
- (lambda _
- (substitute* "configure"
- (("test -d [$]UUCPLOCK") "true")))))))
+ (list
+ #:configure-flags
+ #~(list "--enable-lock-dir=/var/lock")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))))
+ (replace 'bootstrap
+ ;; autogen.sh needlessly hard-codes aclocal-1.14.
+ (lambda _
+ (invoke "autoreconf" "-vif")))
+ (add-before 'configure 'patch-lock-check
+ (lambda _
+ (substitute* "configure"
+ (("test -d [$]UUCPLOCK") "true")))))))
(native-inputs
- `(("autoconf" ,autoconf-2.71)
- ("automake" ,automake)
- ("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
+ (list autoconf-2.71 automake gettext-minimal pkg-config))
(inputs
(list ncurses))
(home-page "https://salsa.debian.org/minicom-team/minicom")